Eclipse: problemi comuni

| | 0 Comments

•    Cannot find a VM (Impossibile trovare una VM)

Eclipse per funzionare richiede una JVM (Java Virtual Machine) che non è inclusa nel download del programma. È necessario, quindi, scaricare una VM ( anche tramite Google). Installata la VM è possibile che Eclipse non riesca a trovarla. Per evitare possibili conflitti, specificare sempre la VM in uso con l’opzione-vm da di comando.

•    Bad VM (VM non valida)

Tutte le versioni della piattaforma Eclipse richiedono almeno un JDK 1.3 VM. Eclipse 3.0 richiede un VM 1.4. Eclipse 3.3 e le successive versioni contengono molti plug-in che non funzionano senza una VM 1.5 o una VM 1.6. Se Eclipse viene eseguito con un VM non conforme alla versione alcune funzionalità potrebbero mancare. Se si riscontrano problemi è bene utilizzare una macchina virtuale affidabile e vedere se il problema scompare. Eclipse, inoltre, non può funzionare se non c’è corrispondenza nell’architettura della JVM e la particolare costruzione di Eclipse che si sta utilizzando. Se si ha un sistema a 64 bit, ma si utilizza una JVM a 32 bit, allora è necessario scaricare la versione a 32 bit di Eclipse. Allo stesso modo, se si utilizza una JVM a 64 bit, allora è necessario scaricare la versione a 64 bit di Eclipse.

•    Unsupported platform (Piattaforma non supportata)

Assicurarsi che l’architettura e il sistema operativo della macchina corrisponde a uno dei sistemi supportati descritti nel file readme_eclipse.html.

•    Lack of appropriate native widget toolkit (Mancanza di adeguati strumenti widget)

Se si scarica, per esempio, la versione GTK di Eclipse è necessario assicurarsi di avere GTK sul computer e che sia installato correttamente. (GTK + 2.2.1 o superiore, per Eclipse 3.3).

•    Incorrectly unzipped (Decompresso in modo errato)

Spesso il problema sta proprio nell’estrarre il programma dal file .rar, prestare particolare attenzione. In Windows il problema si ha in particolare, durante l’installazione, nei percorsi con nomi relativamente lunghi. Può anche essere segnalato che il file zip richiede una password.

•    New Eclipse unzipped on top of older Eclipse (Nuovo Eclipse decompresso sul vecchio Eclipse)

E’ importante installare Eclipse in una cartella nuova o utilizzare Eclipse Update Manager per aggiornare un vecchio Eclipse. Il vostro vecchio spazio di lavoro può essere mantenuto. Consulta il file readme di Eclipse per maggiori dettagli.

•    Xerces problem (Problema con Xerces)

Eclipse utilizza una versione di Xerces per il parsing di file XML,  però alcune distribuzioni della  JVM 1.4 hanno incluso una versione diversa di Xerces ma con i nomi dei pacchetti uguali. Questo non dovrebbe essere più un problema con Eclipse 3.0 o versione superiore.

•    Disk full or out of memory (Disco pieno o uscita dalla memoria)  

Eclipse, in particolare le versioni 2.1 e precedenti, non sempre hanno buoni rapporti con dischi pieni o errori del tipo out-of-memory. Assicurarsi di avere spazio sufficiente sul disco e che si stia spazio a sufficienza anche alla JVM.

Tags: , , , , ,

Category: Software

About the Author ()